【综合复习_网络部分】

网络部分复习

Windows部分学习

  • 如何查看SID
 > whoami /user
  • SID 是什么
是用户唯一安全标识符,是标识用户、组和计算机帐户的唯一的号码
  • 内置用户的分类
->和用户相关的账户(Administrator , Guest)
->与Windows组件相关联的账户(system, local_service, network service)
  • 组的分类
->需要人为添加的
		- Administrators
		- Guests
		- Power Users
		- Users
->需要动态添加的
		- interactive
		- Authenticated
		- Everyone
  • 如何建立用户并把他添加到管理员组
 > net user Admin 123 /add
 > net localgroup administrators Admin /add
  • 管理权限规则
 > 权限冲突,拒绝优先
 > 权限不冲突,,权限累加
 > 权限继承: 下一级默认继承上一级权限
 > 强制继承: 文件夹有强制继承的权限, 一票否决权。
 > 阻止继承: 可以阻止继承上一级权限(添加:表示不删除,可以修改;删除:表示全部清空)
  • 【命令】打开组策略命令
 > gpedit.msc
  • 【命令】打开本地安全策略
 > secpol.msc
  • 【命令】强制安全策略生效
> gpupdate/force
  • 磁盘分类与介绍
> MBR基本分区
	- 不能连续储存
	- 不能提高读写效率
	- 无可靠性(支持分区容量有限,最大支持2T)
> GPT动态分区
	- 可扩展性(磁盘容量不够可以加)
	- 高读写性(比如带区和RAID5可多盘同时读写)
	- 高可靠性(比如RAID5可以修复)
  • 系统是如何开机找系统的
引导系统446字节64字节的分区表(最多可以分四个盘)2字节标识位(表示分区结束)
分区
分区
分区
分区
  • 磁盘的不同类型和优缺点
卷类型需要磁盘数量空间是否一致可扩展性读写性能容错空间利用率
简单卷1可扩展正常读写100%
跨区卷2-32可扩展正常读写100%
带区卷2-32不可扩展多盘读写 (最快)100%
镜像卷2不可扩展正常读写50%
RAID-53-32不可扩展多盘读写n-1
  • DHCP使用的端口
66 67

- DHCP服务器和客户端的通信

服务器-------------------------客户端
  <---DHCP_Discover广播包求服务器--        #(@0.0.0.0 255.255.255.255 客户端请求IP)//广播只有局域网中作用,因因为有路由器(隔离广播)
  ---DHCP_Offer 宣称服务器存在--->         #(source@192.168.10.10 dest@255.255.255.255 offer@192.168.10.101)
  <---DHCP_Request广播包求IP----		   # (选择服务器 192.168.10.10 源地址 0.0.0.0 )
  ---DHCP_ACK 确认租用 --->
  • DHCP 租用规则
客户端------------------------------服务器
 	- IP地址到达租期的**50%**,发送*DHCP request* 更新租约(8天租期,第四天更新租约,租约更新重新当作第一天)
 	- 如果50%租期不成功时,**87.5%** 时再次续约一次
  • 计算机重启,DHCP工作的方式
	客户端--------------------------------服务端
	- 客户端发送 DHCP request
	- 服务器发送 ACK 确认信息(如果IP没给别人用)
	- 服务器发送NAK否认信息(如果IP给别人用了)
  • 如何查看隐藏分享文件
\\@IP \ <filename>$
  • net share 的使用
net share ipc$ #开启ipc$共享
net share ipc$ /del #删除ipc$共享
net share c$ /del #删除C:共享
  • NTFS和共享文件权限问题
谁研究听谁的,取最小交集
		- NTFS 可读可写
文件				    ->只读
		- 共享文件 只读
  • FTP 使用端口
20 21 
  • HTTP使用端口
80

- ftp 被动和主动
被动模式

服务器------------------------------------客户端
1024  21                               2000 2001
       <---发送Pasv告诉服务器被动连接------
       ----好的,服务器用1024与你连接------
 <---------客户端拿1024 与服务器进行连接--------
 ---------------------好的-------------------->

主动模式

服务器------------------------------------客户端
20  21                                2000 2001
     <--发送Port声明主动连接,使用2000端口-
     ----好的,服务器用1024与你连接------->
 ---------服务器用20 端口进行数据连接----------->
 <--------------------好的---------------------
  • FTP 服务默认根目录
> c://inetpub/wwwroot
  • FTP实现用户隔离
在ftproot文件夹里新建一个localuser,然后再localuser里,根据用户名建与用户名一样的文件夹。
把依靠路径换成www/localuser
把模式换成全局禁用虚拟账户
路径://c://inetpub/ftproot
  • 如何在服务器上运行多个网站
- 同@IP,不同端口
- 不同@IP,同端口
- 同@IP,同端口,不同主机名
  • 域名结构
XXXX.bihuo.com
  组件主机名+顶级域名
  • 修改域名的地址
file:///C://windows/system32/divers/etc/hosts

- DNS分类

> 主要名称DNS服务器(权威应答:靠文件给答案)
> 辅助名称DNS服务器(权威应答:靠文件给答案)
> 主控名称服务器(非权威应答:听别人说的,不可更改)
> 缓存DNS服务器(非权威应答:听别人说的,不可更改)
  • 【命令】如何查看域名
> nslookup 
  • DNS查询分类方式
- 查询分类
> 递归查询(递出去,收回来有答案)
> 迭代查询(递出去,反复交替出去)
- 解析分类
> 正向解析
> 反向解析

[域环境】

  • 活动目录是什么
活动目录是Windows的一种服务,是一个数据库,里面存放着用户,组的各种信息,是域的核心,活动目录方便集中管理和扩展
  • 安装域环境的命令
> dcpromo.exe
条件: 静态IP
	 版本必须是2003 以上的
	 NTFS分区
	 Administrator	
  • 域环境AD和DC是什么
> AD:Active Directory活动目录
> DC:Domain_Control域控制器
	  是安装了活动目录的一台服务器
>OU:基本单元
	  像文件夹一样存放用户的信息
  • 如果创建域环境不成功的原因可能是什么
1. 可能没有静态@IP
2. 版本低于域林/域服务器
3. 无法解析DNS
4. 防火墙没关
  • 功能级别条件
1. 林功能限制域功能
2. 域功能限制域控制器

[思科网络]

  • 私有@IP
10.0.0.0 - 10.255.255.255
172.16.0.0 -172.31.255.255
192.168.0.0 - 192.168.255.255
  • 互联网发展的三个阶段
> 分组交换
> TCP
> Web技术
  • 协议的定义
双方达成一致(语义语法),从而可以进行信息的交互和沟通
  • OSI七层
UDP作用协议设备目的
应用层数据为软件应用提供接口Http,DNS,SNMP,SMTP计算机端到端
表示层数据语法,语义,加密,压缩计算机端到端
会话层数据建立session会话连接计算机端到端
传输层进程通信TCP,UDP防火墙
网络层IP实现不同网段的信息传输arp, ip, icmp, rarp, iGmp路由器点到点
数据链路层MAC实现同网段的交互交换机点到点
物理层比特流透明的比特位传输网线,网卡,中继器点到点
  • T568A&T568B
 T568A: 白绿 绿 白橙 蓝 白蓝 橙 白棕 棕
 T568B: 白橙 橙 白绿 蓝 白蓝 绿 白棕 棕
 同级设备使用交叉线
 不同级设备用直通线
标准线: 两条线线序一样
交叉线: 一头T568A,一头T568B
  • MAC地址
以太网地址用来识别一个以太网上的单独或者一组设备
|00 0**6**|1B A3|93 6C|00 0D|28 BE|B6 42|
24  IBM 生产商标识
24 是根据用户对应的网卡编号
  • 帧格式 Ethernet 格式
前导码(7) 起始帧标识符(1) 目的地址(6) 源地址(6) 类型(2) 数据(46-1500) CRC校验帧(4)
  • 交换机原理
1. switch 接受数据帧,根据MAC地址更新MAC表,根据目标地址做决定
2. 未知单播帧和广播帧,则泛洪
3. 如果是已知单播帧,则转发到相应端口
4. MAC地址更新
  • CISCO四种模式
5. 用户模式:查看最简单的信息,比如版本
6. 特权模式:能够查看对switch的配置
7. 全局配置模式:可以对switch进行各种配置
8. 接口配置模式:可对某一接口进行配置
  • 双工模式
1. 单工模式: 单向通信
2. 半双工模式: 可以双向,但发时不收
3. 全双工模式: 自由双向通信

当速率不匹配时不能够通信 
  • IP数据包
版本(4) 首部长度(4) 优先级和服务类型(8) 总长度(16)
标识符(16) 标识(3) 段偏移量(13)
TTL(8) 协议号(8) 首部校验码(16)
               源(32)
               目标(32)
               可选
               数据
  • ABCDE类网分类
A: 1.0.0.0 - 126.255.255.255
B: 128.0.0.0- 191.255.255.255
C: 192.0.0.0 - 223.255.255.255
D:224.0.0.0- 240.255.255.255
E: 241.0.0.0- 255.255.255.255
  • 远程管理思科交换条件
1. 配置IP
2. 需要两个密码
	- enable password 123
	- line vty 0 4 
	- password 123
	- login 
远程的方式: telnet @IP 
			密码

-Cisco配置的快捷配置

1. 去掉DNS查找
	no ip domain-lookup
2. 防超时
	line console 0
	exec-timeout 0 0 
3. 防止被消息打断
	logg synchronous
  • ARP 的作用
网络层地址解析协议,根据IP地址找到MAC地址,实现自动学习MAC地址表,请求消息时广播,回复是单播
  • 路由器的工作原理
自动学习路由表
根据网段和端口确定数据包流向
  • 路由表格式和类型
网段-------- 端口--------- 下一跳

直连网段
非直连网段
默认网段
  • 显示端口IP信息的指令
> show ip interface brief
> show ip route
  • DHCP 配置指令和条件
路由器有配置静态IP
# ip dhcp pool test  
# network 网段 子网掩码
#default-route 网关地址
#dns-route DNS服务器IP地址
如果需要排除IP需要退出去全局配置模式下
# exhau=====忘了
  • VLAN的作用
vlan虚拟局域网
- 为了解决交换机的带来的过大的广播域,造成带宽的浪费,解决的MAC地址表过大,从而效率过低
- 将网络分成多个虚拟局域网,分割广播域,实现逻辑隔离, 更加安全
  • TRUNK中继的作用
trunk 实现不同交换机在同一vlan的通信
    -ISL思科专有协议
    -IEEE802.1Q
  • 接入链路的分类
- access 接入链路
- trunk 中继链路
  • 以太网的作用
把多个接口捆在一起,1. 提高带宽 2. 链路冗余互为备份
  • CEF是三层交换机(拓扑转发原理)
- 转发信息库(相当于路由表)
- 邻接关系表(相当于MAC表)
  • 三层交换机端口开启路由
> ip routing
> no sw
  • STP生成树协议
解决多个交换机环路问题
  • STP选举标准
堵塞一个端口,形成逻辑树,从而避免环路
1. 选择根网桥(选择网桥ID最小的,先比较优先级,在比较MAC地址,最小的成为根网桥)
2. 根端口(路径成本小的成为根端口)
3. 指定端口(除了根网桥之外的,与根网桥相连的是指定端口)
		- 路径成本低
		- 所在交换机网桥ID小
		-  发送端ID小
  • HSRP是什么
思科私有协议,热备份路由选择协议

- HSRP的角色分类

- 活跃路由
- 备份路由
- 虚拟路由
- 其他路由
  • HSRP的路由配置
> 进入vlan端口
> ip address 192.168.10.1 255.255.255.0
> standby 组号 ip 192.168.10.123 (配置虚拟IP)
> standby 组号 priority 200
> standby 组号 preempt 
> standby 组号 timers 2 8
> standby 组号 track fastEhernet 0/1 10
  • 显示STP和热备路由状态命令
> show spanning-tree 
> show standby brief
  • ACL 定义
访问控制列表 (access control list),
是由一系列条件规则组成, 这些条件规则可以是报文的源地址、目的地址、端口号等,是一种应用在网络设备各种软硬接口上的的指令列表。使得网路更加安全
  • ACL应用过程
数据包进入时,检查有没有ACl-表,从第一条开始检查,如果通过则不检查第二条,以此类推,进入路由器根据路由表转发丢弃, 转发进入acl-out检查, 从第一条开始,通过则放行,不同则检查下一条, 全部不同则丢弃
  • ACL的分类
- 标准ACL :  基于源@IP过滤数据包。 协议号1-99
- 扩展ACL :  基于源IP,目标IP,端口, 协议的过滤 100-199
- 可命名 (标准&可扩展): 使用名称代替表号
  • ACL配置
标准:
# access-list 10 permit @ip
# ip access-group 10

扩展:
# access-list 120 permit ip @ip @子网反码 @ip @子网反码 eq www/ftp/domain
# ip access-group 120

可命名:
# ip access-list extends haha
# 20 permit tcp host 192.168.1.2 host 192.168.3.5 eq www
进入端口
# ip access-group haha in/out
  • NAT的定义原理
Network address Translation,网络地址转换
优点:
   1. 节省公有合法IP,
   2. 处理地址重叠
   3. 增强灵活性
   4. 安全性
缺点:
	1. 延迟增大
	2. 配置和维护的复杂性
	3. 不支持某些应用,需要通过静态NAT映射来避免
  • NAT 的分类

1.静态
在这里插入图片描述

Route(config)#interface FastEthernet 0/0
Route(config-if)# ip address 61.159.62.130 255.255.255.248
Route(config-if)# no sh 
Route(config)#interface FastEthernet 1/0
Route(config-if)# ip address 192.168.100.1 255.255.255.0
Route(config-if)# no sh 
Route(config)# ip nat inside source static 192.168.100.2 61.159.62.130
Route(config)# ip nat inside source static 192.168.100.3 61.159.62.131
Route(config)# interface FastEthernet 0/0
Route(config)# ip nat outside
Route(config)# interface FastEthernet 1/0
Route(config)# ip nat inside
配置默认路由:
Route(config)# ip route 0.0.0.0 0.0.0.0 61.159.62.**129**

静态端口映射
在这里插入图片描述

配置默认路由:
Route(config)# ip nat inside source static TCP 192.168.100.2 80 61.159.62.131 8080 extenable

2.动态
在这里插入图片描述

Route(config)#interface FastEthernet 0/0
Route(config-if)# ip address 61.159.62.130 255.255.255.192
Route(config-if)# no sh 
Route(config)#interface FastEthernet 1/0
Route(config-if)# ip address 192.168.100.1 255.255.255.0
Route(config-if)# no sh 
#定义访问控制列表#
Route(config)# access-list 1 permit 192.168.100.0 0.0.0.255
#定义合法的IP地址池#
Route(config)# ip nat pool test0 61.159.62.131 61.159.62.190 netmask 255.255.255.192
#定义访问控制列表#
Route(config)# ip nat inside source list 1 pool test0
#在内部和外部端口启用NAT,以及配置默认路由域静态NAT 配置相同# 

3.PAT

在这里插入图片描述

Route(config)#interface FastEthernet 0/0
Route(config-if)# ip address 61.159.62.130 255.255.255.192
Route(config-if)# no sh 
Route(config)#interface FastEthernet 1/0
Route(config-if)# ip address 10.1.1.2 255.255.255.0
Route(config-if)# no sh 
Route(config)# access-list 1 permit 10.1.1.0 0.0.0.255
Route(config)# ip nat pool onlyone 61.159.62.131 61.159.62.131 netmask 255.255.255.248
Route(config)# ip nat inside source list 1 pool onlyone overload
#在内部和外部端口启用NAT,以及配置默认路由域静态NAT 配置相同# 

设置复用动态IP地址转换

Route(config)# ip nat inside source list 1 ibterface FastEthenet 0/0 overload
  • 查看NAT转化条目
Route(config)# do show ip nat translation 
  • 清除NAT转化表
Route(config)# clear ip nat translation *
Route(config)# clear ip nat translation inside local-ip global-ip
Route(config)# clear ip nat translation outside local-ip global-ip
  • 命令跟踪NAT操作
> debug ip nat
  • OSPF的DR和BDR选择过程
1. 自动选择DR和BDR 
    选取路由器loopback接口上数值最高的IP地址,如果没有loop back接口,在物理端口中选取IP地址最高的,
	也可以选择网段RouteID最大的路由器会成为DR,第二会成为BDR
2. 手工选择
	- 优先级0-255,数值越大,优先级越高,默认是1
	- 优先级相同比较routeID,大的成为DR
	- 优先级为0,不参与选举
  • OSPF的优点
- 路由变化收敛速度快
- 路径经过Dijek的算法,更优
- 可达距离更远
- 适用于大型网络
- 支持区域划分
- 支持变长的子网掩码VLSM
- 支持以组播地址发送协议报
已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 点我我会动 设计师:上身试试 返回首页